말똥이의 블로그

Multi-parameter attributes를 Mongoid 4.0에서 지원시키기 본문

Multi-parameter attributes를 Mongoid 4.0에서 지원시키기

ryush00 2015.03.11 17:28

Mongoid 4.0 버전에서 Multi-parameter attributes가 제거되었다고 합니다. (쓰레드 링크)


datetime_select 를 사용 못하게 된겁니다.


그래서 어떤 외국의 능력자 뿐께서 4.0에서도 사용 가능하게 제작하셨습니다.



아래 multi-parameter_attributes_spec.rb multi_parameter_attributes.rb 파일을 lib 폴더에 넣으신 후 애플리케이션 설정에


config.autoload_paths << Rails.root.join('lib')

소스를 추가해 주시면 됩니다.




출처: http://roodyruby.tumblr.com/post/67651747866/multi-parameter-attributes-support-for-mongoid-4-0

0 Comments
댓글쓰기 폼